Looks like you're in . Change  Confirm

Home / Help centre / Troubleshooting / Why is my Powershop app telling me that I need to update it?

Help centre

Our aim is to help make things simpler not harder.

Why is my Powershop app telling me that I need to update it?

Help topic:

To use the Powershop app, you’ll need an iPhone using iOS 10 (or above) or an Android phone using 4.0.3 (or above) with a screen quality of 470dp x 320dp.


If you aren’t able to upgrade your operating system to either of the above, you’ll still be able to access your account online through our website.


Browse help topics

Still have questions?

1800 462 668 info@powershop.com.au